Issue#460158: Ubuntu - [SOLVED] Found a ddclient bug when retry=yes (ddclient won't update)

  • I've just spent too many hours debugging why ddclient wouldn't update when the ip address changed. The issue is worth sharing because others must definitely be having this problem.

    The culprit turned out to be a combination of retry=yes in the config and this piece of code in /usr/sbin/ddclient

    Code:

        if (opt('retry')) {
            @hosts = map { $_ if $cache{$_}{'status'} ne 'good' } keys %cache;
        }

    As far as I can tell it maps your config against a cache which hasn't been loaded yet (Like that's not a major bug) and the consequences are that it discards your config. Later on it loads the cache and without any config it presumes there's nothing to do and exits.
    My solution is to comment out that code because it's ultra dumb and because I don't know enough perl nor have the background with ddclient to ensure the cache is loaded before it does this check.

    0 Answers

    Sorry, your answer is too short !

  • Issue#18827: Ubuntu - [SOLVED] Nikon DSLR Firmaware Update

    Today in the morning I got a message from Nikon that there is a new Firmware available for my D5300 but unfortunately Nikon provides only firmware for Windows and MAC. After a lengthy research and reading different forums I managed to upgrade the DSLR using only linux (Mint) I do believe that the below steps will work for most of the Nikon DSLR's I am not much of a big Linux magician but I use only Linux on all my devices for a year or so now and I hope that with this I can help similar users than me, by saving a lot of time for them searching the web. 1. If you did not register your Nikon D5300 with Nikon than here is the link ... If you have a different model than be sure to find the page for your exact Nikon model because while the instructions are similar, the firmware files are not. 2. Download the Windows Firmware 3. In Terminal Navigate to the file for me it was cd Downloads cd Nikon_D5300Firmware 4. Unpack the file with unrar e F-D5300-V101W.exe ( unrar e filename) 5. Form

  • Issue#26590: Ubuntu - [SOLVED] 14.04 libnl update broke Network Manager and Network

    I had the "pre-released updates" box checked in my software updates. When I did an update yesterday and rebooted, I lost wired/wireless networking and Network Manager wouldn't start. Code: dmesg | grep network-manager kept showing segfaults. I tried various things, but nothing worked until I manually rolled back the update. I had to download the previous versions of libnl (see the following log file) from http://packages.ubuntu.com/source/trusty/libnl3 on another computer and transfer them via flashdrive then install them with Code: sudo dpkg -i *.deb I got my networking back after that. Code: LOGFILE Commit Log for Thu Jan 28 16:18:10 2016 Upgraded the following packages: libnl-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 libnl-genl-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 libnl-route-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 Hope this helps anyone with the same problem.

  • Issue#28282: [ubuntu] After repeated tries to fix, Ubuntu won't recognize HP printer after update

    After a recent kernal update of Ubuntu 12.04 on my Compaq Presario CQ61-313US notebook, my HP Photosmart D110 which previously printed and scanned flawlessly is no longer recognized in any of the USB ports which all function using other devices. I also have Lubuntu 14.04 installed on another partition of this computer, and the same problem exists there as well. I've been researching this problem heavily, and it seems to be prevalent with the newer versions/updates of Ubuntu (and Linux Mint) and HP printers. Unfortunately, non of the remedies I've seen and tried have worked for me. Running the command “sudo hp-setup” yields the following output: ***********Presario-CQ61-Notebook-PC:~$ sudo hp-setup HP Linux Imaging and Printing System (ver. 3.13.11) Printer/Fax Setup Utility ver. 9.0 Copyright (c) 2001-9 Hewlett-Packard Development Company, LP This software comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to distribute it unde

  • Issue#39046: Found an old ubuntu CD - can I update after installation?

    I found an old 14.01 Ubuntu LTS, and I see that now it's 14.03 LTS. Is it possible to install the 14.01 and then update to 14.03 through Ubuntu itself? Thanks

  • Issue#45042: Ubuntu Software Update Error/Issue

    I installed 14.04.3 on a new laptop at the weekend and when trying to run updates I'm getting an error "Error:Broken Count>0" I've hunted around looking for some guidance but come up empty. I did run 2 commands in Terminal (sudo apt-get update and sudo apt-get upgrade) following a suggestion on another thread. Results below: Code:                         [email protected]:~$ sudo apt-get update   Ign http://archive.ubuntu.com trusty InRelease   Hit http://archive.ubuntu.com trusty-updates InRelease   Hit http://archive.ubuntu.com trusty-backports InRelease   Hit http://archive.ubuntu.com trusty-security InRelease   Hit http://archive.ubuntu.com trusty Release.gpg   Hit http://archive.ubuntu.com trusty-updates/main Sources   Hit http://archive.ubuntu.com trusty-updates/restricted Sources   Hit http://archive.ubuntu.

  • Issue#46804: [ubuntu] update hung up, now Ubuntu 14.04 won't start

    14.04 LTS on desktop machine, used software update. It hung up after asking about replacing a configuration file, so I rebooted. I enter my password, screen goes blank, and then I get the sign on screen again. Over and over. Tried "fix packages" in recovery mode, no luck. Any ideas? Thanks, Henry

  • Issue#80882: Linux - LXer: Ubuntu Touch Users Report Serious Bug That Causes Dropped Calls After OTA Update

    Published at LXer: A few Ubuntu Touch users are reporting that a serious bug is affecting the operating system, causing the calls to drop, and they are asking developers to hurry up with an update. Read More...

  • Issue#147976: [ubuntu] system won't boot after 14.04.4 update

    Hello, I've just installed update for Trusty by Quote: https://wiki.ubuntu.com/Kernel/LTSEnablementStack After reboot the system can fully bootup only in recovery mode... Can you help me to fix it or to revert changes? Can I just remove the installed packages by: Quote: sudo apt-get -r linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386 Thanks in advance!

  • Issue#167881: Ubuntu - HELP! Received Update- Won't Boot

    I received this morning's update, & now the system won't boot. I reinstalled Xubuntu from a 14.10 disc, upgraded back to 15.10, & got the same result. I waited 10 min, staring at the blank/black screen, hoping it would eventually continue. Nothing happened. I walked away, & came back 17 min later.... still nothing. No indication of hard drive activity. Zip. Zilch. Nada. I can only assume this is a compatibility issue with the update, since my laptop is very old. Unless there is some way to make it work again? I have a lenovo t-400. I'm not too happy about spending money on a new laptop, but if I must....

  • Issue#188285: Ubuntu - [SOLVED] UPDATE: LinUX-native office and Bible-manager packages compatible with OpenLP?

    As of 26 February 2016 I am testing UbuntuGNOME® 16.02b1 on an eMachines®/Acer® EL1210-09 upgraded with a Shuttle® PC6300001 power supply and msi® N610GT-MD1GD3/LP video display adapter. Since the close of Thread 2195723, the original Question has in fact been answered: FIX RELEASED: OpenLP® 2.4.1 This release restores compatibility lost with the original release of LibreOffice® 5, which broke OpenLP® 2.0.n.

  • Issue#211784: [SOLVED] how to get thinkorswim working on ubuntu 14.4 after their recent update

    Recent updates to the thinkorswim java program caused that to stop working on my system. It was pretty frustrating because it wasn't clear what was wrong. All that would happen was that the launch process never got past the "installing updates" stage. Btw I have ubuntu studio 14.4 64 bit. Searching around I discovered that on Jan 23rd they had posted this: https://tlc.thinkorswim.com/center/r...1-23-2016.html saying that they had moved their code base to java 8. Fortunately some of the people in thinkorswim tech support are sympathetic to linux users even though linux is not officially supported. I managed to have a chat session with one of them, who was very helpful. First, you now need to have java 8, and you need to get the Oracle version. The best way imo to get that is to use the ppa from the wonderful folks at webupd8.org: Code: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer In my case since I had al

  • Issue#226045: Lenovo - Lenovo vibe x3 battery drain issue not solved in the new update

    A new update s138_160301 after the 317mb s137_160222 update did not solve the battery issue .battery is draining fast as compared to what was when i purchased the phone.Dolby speaker were restored to normal but battery drain issue has not been addresed.Lenovo please work on this too as without a good battery backup flagship phone is reduced to nothing

  • Issue#228085: Lenovo - (49MB) update fix only display bug and increase in sound not sound quality, battery issue

    After i updated (317MB) with bugs, i waited for another update to fix diplay, sound and fast battery draining problems however when i update another (49MB) it fix display issue and increse in sound not the sound quality and battery draining not solved. please give an update for sound quality and battery issue ASAP.

  • Issue#289982: Ubuntu - repo won't update but program still does.

    Update manager is constantly telling me some files weren't loaded. The problem seem to be google. So I uncommented it and tried refreshing and got the same error. This is the error Code: W:Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file) , E:Some index files failed to download. They have been ignored, or old ones used instead. I think that Ubuntu is updating google-chrome-stable from it's own repo so this other one is not needed but I can't figure out why it thinks it can't connect to the internet.

  • Issue#325240: New issue or bug in update

    ImageUploadedByiMore Forums1458622090.780839.jpg When I'm creating a contact manually, the birthday and anniversary dates are adding up like this. Anyone knew about it? Or facing it? Please help it's annoying Attached Images ImageUploadedByiMore Forums1458622090.780839.jpg (120.0 KB)

  • Issue#362811: Ubuntu - [SOLVED] Firefox / Yahoo Issue

    O.k.....Now that I have reset the password, I have managed to clean quite a bit of ''clutter'' off this little netbook.......however, the one thing I can't figure out is why, when clicking on the Firefox icon, Yahoo opens as the browser......I can't set Firefox to default browser because it does not open at all.......it just goes straight to Yahoo......anyone know why ?.......Del.

  • Issue#396606: Finally found a fix for Creative Cloud app update issue/errors on Mac running YOSEMITE

    A tip for those on Macs who have not yet solved a problem downloading the Creative Cloud app update. If like me, you have tried everything...uninstaller, installer, CC cleaner, manually removing files...I ended up with multiple errors (2 and then 43 were the repeats), and in the process made a mess of my programs... If you have been searching in vain for a solution, I hope that mine will work for you, too. I went to system properties and created a new user account with admin privileges. From the new admin account on my Mac,  I downloaded the old Adobe application manager for Mac from the adobe site. The old Adobe application manager automatically updated to the newest Creative Cloud app.I logged in to Creative Cloud to confirm that I did not have any issuesI logged out of Creative Cloud and then out of the new admin account that I created solely for this purposeI logged back in to my usual admin account, opened and logged in to the Creative Cloud App.I deleted the extra admin acco

  • Issue#417473: Ubuntu - [SOLVED] Update's if you have a custom kernel.

    Will apt suggest or install "new" kernels if you currently run the newest stable one? ex: I am now on 4.6.0-040600rc2-generic, my latest kernel from repository is: 4.4.0-17-generic. Will i get an update when 4.4.0-18-generic is released?

  • Issue#450857: [ubuntu] computer won't boot after update

    Hi, I recently installed some updates on my computer running Ubuntu 14.04 LTS. After that the computer would not boot. I also could not access the GRUB boot loader. So I followed the advice on this page https://help.ubuntu.com/community/Boot-Repair: I created a disk with Boot-Repair from https://sourceforge.net/p/boot-repair-cd/home/Home/ I booted the computer with the Boot-Repair disk and clicked on 'Recommended repair' After that I was able to access GRUB I clicked on 'recovery mode' and reached the recovery mode menu. However, none of the options in the recovery mode menu seemed to work. Boot-Repair created a report and pasted it to https://paste.ubuntu.com/15660599/ Help in understanding and solving this problem would be much appreciated. Please explain things in very basic terms - I am still a newbie re UNIX/Ubuntu. Cheers, Phil

  • Issue#468181: After an update of my Nvidia drivers, Ubuntu won't boot.

    Hello, I am kinda new to Ubuntu so please be patient. I've been having difficulties with my Nvidia drivers. I was never able to shutdown my pc without the screen freezing on my desktop, forcing me to manually force shutdown. I found on some forums that this could be because of my Nvidia drivers. So I switched from the Nouveau drivers to a proprietary one, rebooted, and Ubuntu never booted again. I can get to Ubuntu, with Linux 4.2.0-27 generic but not Linux 4.2.0-35 generic. Also, even on this kernel, Ubuntu will randomly freeze (often when I try to access Software and updates). Feel free to ask me to run certain commands for info. Thanks in advance.

  • Issue#488846: Xbox One Bug/Issue found

    First time I load game up I do full run round base of operations collecting weapon parts and tools etc but after that I can collect everything else except tools. I can only collect it once a day!

  • Issue#497811: Android - Voice Mate Won't Work Offline, Marshmallow Update Issue?

    I was able to use my Jabra blue tooth with voice mate on my LG G3 offline no problem and now I no longer can use my blue tooth to call hands free. It wants me online. I have tried to find an app that works offline to no avail. It is so frustrating that Android wants us online to make a stupid... Voice Mate Won't Work Offline, Marshmallow Update Issue?

  • Issue#498971: [ubuntu] Won't boot. possibly Update related.

    I was in the middle of installing some updates on my desktop. The update crashed multiple times. I decided to reboot. System hung while trying to reboot and I had to do a hard-reset. GRUB comes up and no matter which option I select I end up with a black screen and a flashing cursor at the top. I booted from a recovery USB. Reinstalled GRUB. No effect. Booted from recovery USB. Went to command line with : Ctrl-Alt-F1 Mounted my old file system like this: sudo mount /dev/sda1 /mnt sudo mount --bind /dev /mnt/dev sudo mount --bind /proc /mnt/proc sudo mount --bind /sys /mnt/sys sudo chroot /mnt Attempted to run apt upgrade. Upgrades download and then the process fails with the following error: Invalid argument: -c E: Sub-process /usr/sbin/dpkg-preconfigure --apt || true returned an error code (255) E: Failure running script /usr/sbin/dpkg-preconfigure -apt || true Every single thing from this point involving apt-get gives me an error involving 'Invalid argument: -c' and a differe

  • Issue#508608: [ubuntu] Ubuntu won't start after update

    My Ubuntu freeze during the upgrade of 15 to 16, now he does not want to start again. after the loading screen it stops at a black screen and does nothing. I tried this tutorial http://ubuntuforums.org/showthread.php?t=2217829 replacing RO for RW but it stop in other black screen. Can someone help me to at least recover my files?

  • Issue#512582: Ubuntu - [SOLVED] Software center bug

    Ubuntu 16.04 https://bugs.launchpad.net/ubuntu/+s...e/+bug/1573052 line from syslog Code: Apr 23 12:51:15 Dell-1749 org.gnome.Software[2562]: (gnome-software:20595): Gs-WARNING **: failed to open plugin /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: /usr/lib/gs-plugins-9/libgs_plugin_xdg_app_reviews.so: cannot open shared object file: No such file or directory

  • Issue#547085: [ubuntu] Firefox won't start after update

    Hi, Firefox tried to update itself, but now it does not seem to start again. When I click the icon in the launcher, it flashes (as if it is about to start), but then nothing happens. I cannot run it with sudo. I'm still running Ubuntu 11.04, though - I don't know if this has anything to do with it. Can anyone help, or offer ideas? Thanks

  • Issue#588757: Ubuntu - Mythweb video won't play remotely: location not found

    I got mythweb working on the same network as the backend. I also got it working from a remote location with the exception that I can't play any of the programs recorded. I get a "location not found" error, which I find odd considering it finds the location of the thumbnails which are in the same directory. I also get a similar response with the mythtv-frontend running remotely: everything seems to work except playing recordings which it says it can't find.

  • Issue#590376: [ubuntu] update manager bug

    greetings, Running Ubuntu 14.04.4 on HP pavillion G6 lappie. No probs for yrs, today update manager stalled and this message shows 'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/au.archive.ubuntu.com_ubuntu_dists_precise_main_bi nary-i386_Packages, E:The package lists or status file could not be parsed or opened.' Any help much appreciated. Ta Chester

  • Issue#604386: Ubuntu - [SOLVED] Wireless networking bug (can only connect by entering)

    I discovered another bug in Lubuntu 16.04 When connecting to a secured wireless network, you have to select the wireless network that you want to connect to, and then on the next screen enter the password. When you click the connect icon (button) nothing happens, but when you simply press enter it connects. Not a major bug, but it confused me in the beginning.