Issue#460158: Ubuntu - [SOLVED] Found a ddclient bug when retry=yes (ddclient won't update)

  • I've just spent too many hours debugging why ddclient wouldn't update when the ip address changed. The issue is worth sharing because others must definitely be having this problem.

    The culprit turned out to be a combination of retry=yes in the config and this piece of code in /usr/sbin/ddclient

    Code:

        if (opt('retry')) {
            @hosts = map { $_ if $cache{$_}{'status'} ne 'good' } keys %cache;
        }

    As far as I can tell it maps your config against a cache which hasn't been loaded yet (Like that's not a major bug) and the consequences are that it discards your config. Later on it loads the cache and without any config it presumes there's nothing to do and exits.
    My solution is to comment out that code because it's ultra dumb and because I don't know enough perl nor have the background with ddclient to ensure the cache is loaded before it does this check.

    0 Answers

    Sorry, your answer is too short !

  • Issue#18827: Ubuntu - [SOLVED] Nikon DSLR Firmaware Update

    Today in the morning I got a message from Nikon that there is a new Firmware available for my D5300 but unfortunately Nikon provides only firmware for Windows and MAC. After a lengthy research and reading different forums I managed to upgrade the DSLR using only linux (Mint) I do believe that the below steps will work for most of the Nikon DSLR's I am not much of a big Linux magician but I use only Linux on all my devices for a year or so now and I hope that with this I can help similar users than me, by saving a lot of time for them searching the web. 1. If you did not register your Nikon D5300 with Nikon than here is the link ... If you have a different model than be sure to find the page for your exact Nikon model because while the instructions are similar, the firmware files are not. 2. Download the Windows Firmware 3. In Terminal Navigate to the file for me it was cd Downloads cd Nikon_D5300Firmware 4. Unpack the file with unrar e F-D5300-V101W.exe ( unrar e filename) 5. Form

  • Issue#26590: Ubuntu - [SOLVED] 14.04 libnl update broke Network Manager and Network

    I had the "pre-released updates" box checked in my software updates. When I did an update yesterday and rebooted, I lost wired/wireless networking and Network Manager wouldn't start. Code: dmesg | grep network-manager kept showing segfaults. I tried various things, but nothing worked until I manually rolled back the update. I had to download the previous versions of libnl (see the following log file) from http://packages.ubuntu.com/source/trusty/libnl3 on another computer and transfer them via flashdrive then install them with Code: sudo dpkg -i *.deb I got my networking back after that. Code: LOGFILE Commit Log for Thu Jan 28 16:18:10 2016 Upgraded the following packages: libnl-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 libnl-genl-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 libnl-route-3-200 (3.2.21-1) to 3.2.21-1ubuntu1 Hope this helps anyone with the same problem.

  • Issue#39046: Found an old ubuntu CD - can I update after installation?

    I found an old 14.01 Ubuntu LTS, and I see that now it's 14.03 LTS. Is it possible to install the 14.01 and then update to 14.03 through Ubuntu itself? Thanks

  • Issue#45042: Ubuntu Software Update Error/Issue

    I installed 14.04.3 on a new laptop at the weekend and when trying to run updates I'm getting an error "Error:Broken Count>0" I've hunted around looking for some guidance but come up empty. I did run 2 commands in Terminal (sudo apt-get update and sudo apt-get upgrade) following a suggestion on another thread. Results below: Code:                         [email protected]:~$ sudo apt-get update   Ign http://archive.ubuntu.com trusty InRelease   Hit http://archive.ubuntu.com trusty-updates InRelease   Hit http://archive.ubuntu.com trusty-backports InRelease   Hit http://archive.ubuntu.com trusty-security InRelease   Hit http://archive.ubuntu.com trusty Release.gpg   Hit http://archive.ubuntu.com trusty-updates/main Sources   Hit http://archive.ubuntu.com trusty-updates/restricted Sources   Hit http://archive.ubuntu.

  • Issue#188285: Ubuntu - [SOLVED] UPDATE: LinUX-native office and Bible-manager packages compatible with OpenLP?

    As of 26 February 2016 I am testing UbuntuGNOME® 16.02b1 on an eMachines®/Acer® EL1210-09 upgraded with a Shuttle® PC6300001 power supply and msi® N610GT-MD1GD3/LP video display adapter. Since the close of Thread 2195723, the original Question has in fact been answered: FIX RELEASED: OpenLP® 2.4.1 This release restores compatibility lost with the original release of LibreOffice® 5, which broke OpenLP® 2.0.n.

  • Issue#211784: [SOLVED] how to get thinkorswim working on ubuntu 14.4 after their recent update

    Recent updates to the thinkorswim java program caused that to stop working on my system. It was pretty frustrating because it wasn't clear what was wrong. All that would happen was that the launch process never got past the "installing updates" stage. Btw I have ubuntu studio 14.4 64 bit. Searching around I discovered that on Jan 23rd they had posted this: https://tlc.thinkorswim.com/center/r...1-23-2016.html saying that they had moved their code base to java 8. Fortunately some of the people in thinkorswim tech support are sympathetic to linux users even though linux is not officially supported. I managed to have a chat session with one of them, who was very helpful. First, you now need to have java 8, and you need to get the Oracle version. The best way imo to get that is to use the ppa from the wonderful folks at webupd8.org: Code: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer In my case since I had al

  • Issue#226045: Lenovo - Lenovo vibe x3 battery drain issue not solved in the new update

    A new update s138_160301 after the 317mb s137_160222 update did not solve the battery issue .battery is draining fast as compared to what was when i purchased the phone.Dolby speaker were restored to normal but battery drain issue has not been addresed.Lenovo please work on this too as without a good battery backup flagship phone is reduced to nothing

  • Issue#362811: Ubuntu - [SOLVED] Firefox / Yahoo Issue

    O.k.....Now that I have reset the password, I have managed to clean quite a bit of ''clutter'' off this little netbook.......however, the one thing I can't figure out is why, when clicking on the Firefox icon, Yahoo opens as the browser......I can't set Firefox to default browser because it does not open at all.......it just goes straight to Yahoo......anyone know why ?.......Del.

  • Issue#396606: Finally found a fix for Creative Cloud app update issue/errors on Mac running YOSEMITE

    A tip for those on Macs who have not yet solved a problem downloading the Creative Cloud app update. If like me, you have tried everything...uninstaller, installer, CC cleaner, manually removing files...I ended up with multiple errors (2 and then 43 were the repeats), and in the process made a mess of my programs... If you have been searching in vain for a solution, I hope that mine will work for you, too. I went to system properties and created a new user account with admin privileges. From the new admin account on my Mac,  I downloaded the old Adobe application manager for Mac from the adobe site. The old Adobe application manager automatically updated to the newest Creative Cloud app.I logged in to Creative Cloud to confirm that I did not have any issuesI logged out of Creative Cloud and then out of the new admin account that I created solely for this purposeI logged back in to my usual admin account, opened and logged in to the Creative Cloud App.I deleted the extra admin acco

  • Issue#417473: Ubuntu - [SOLVED] Update's if you have a custom kernel.

    Will apt suggest or install "new" kernels if you currently run the newest stable one? ex: I am now on 4.6.0-040600rc2-generic, my latest kernel from repository is: 4.4.0-17-generic. Will i get an update when 4.4.0-18-generic is released?

  • Issue#615488: Ubuntu - [SOLVED] networking removed after update

    hi, Just updated my desktop xubuntu 14.04 LTS, amd64 machine , and noticed the network was not working. Luckily I had another machine and went online and used this solution, in case anyone else has same thing happen. I went to http://askubuntu.com/questions/72712.../727462#727462 and followed the instructions to download and install the old network-manager. I needed these three files for my amd64 machine: Code: libnl-3-200_3.2.21-1_amd64.deb http://archive.ubuntu.com/ubuntu/poo...21-1_amd64.deb libnl-genl-3-200_3.2.21-1_amd64.deb http://archive.ubuntu.com/ubuntu/poo...21-1_amd64.deb libnl-route-3-200_3.2.21-1_amd64.deb http://archive.ubuntu.com/ubuntu/poo...21-1_amd64.deb if you have i386 machine, these files: http://archive.ubuntu.com/ubuntu/poo....21-1_i386.deb http://archive.ubuntu.com/ubuntu/poo....21-1_i386.deb http://archive.ubuntu.com/ubuntu/poo....21-1_i386.deb then, using terminal, I went into the folder were they were saved and did this: Code: sudo dpkg -i libnl-*.d

  • Issue#730803: Ubuntu - [SOLVED] php5-mysql package not found.

    Hi, I'm trying to install a LAMP server. I looked at search to find the answer however the fix is not there. Ran the following command: Code: --------- sudo apt-get install php5-mysql --------- And got This:

  • Issue#731522: Ubuntu - [SOLVED] apt-get update problem

    I typed in the command "apt-get update" into my terminal {without the woutations obviously} and it returned:E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)E: Unable to lock directory /var/lib/apt/lists/E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?I have ubuntu installed on my hp chromebook through crouton. Any way to fix this?

  • Issue#826561: [SOLVED] Ubuntu update grub loader question

    I have a laptop that Windows is installed on. I installed Ubuntu 14.04 on a USB drive (using Yumi). The laptop is setup to boot from USB. So on start up, it defaults to Ubuntu unless I manually select windows. I've been running this configuration for two years. The Ubuntu updates have never been a problem. Now, I am just updating a ubuntu security update. Part of the update is a grub-pc update. During the update, I received a popup window : Configuring Grub PC. And then it lists 3 "grup install devices" with checkboxes to be selected. The 3 are: dev/sda (my 500 GB laptop drive) dev/sdb (my USB device that I have Ubuntu loaded on) dev/sdb1 (I believe this is a USB device that I sometimes insert and boot from ... this device is not currently inserted) I'm stuck at this point of the update, because I do not know what am I suppose to do. Am I to select all 3 check boxes? I would guess that I should only select device dev/sdb but am unsure and do not want to mess up my system..

  • Issue#845572: Ubnt - ER5 need update/set cmd to define dns options line for ddclient to set ddns mx record for ema

    After reviewing the ddclient code, I modified /config/config.boot to include an "options" line in dns->dynamic->interface->service section with mx server information to support an email server via ddns. This change works as expected.However, config.boot gets replaced whenever a change is made via the EdgeOS GUI.I've attempted to make the same change to config.boot using the update command.However, update does not accept the options line.How should I add the options line to config.boot?  dns{dynamic{interface eth0{service dyndns{host-name x.comlogin abcdefgpassword XXXXXXXXXXXXXXXXXXXXXXXXprotocol dyndns2server members.dyndns.orgoptions mx=192.168.1.180,backupmx=no,wildcard=no}web dyndns}}

  • Issue#888291: Ubuntu - [SOLVED] How do I roll-back a recent change/update? (new power management problem)

    The problem no longer appears. I can't explain it. The forum does not allow me to delete this post. Sorry.

  • Issue#933871: [ubuntu] Update Issue (Not Enough Disk Space in Boot?)

    Hello all! I just recently got back into using Ubuntu on my laptop. I love how it has gotten easier than it was 10 years ago! This afternoon, I went to update via the Software Updater and I got an error I have never seen before... I performed sudo apt-get clean, but it did not resolve the issue. I checked my hard drive, and I have almost 300 gigs free... not sure what to do. Any advice? Thanks!

  • Issue#943267: [ubuntu] Update error: failed to fetch a file not found (404)

    I am getting the following error while trying to update my Ubuntu 16.04 LTS. I have tried to get reuse the old backup status files but that does not seem to work. Any help will be much appreciated. Thanks a lot in advance! Code: sudo apt-get update [sudo] password for shabbar: Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease Hit:2 http://de.archive.ubuntu.com/ubuntu xenial InRelease                    Hit:3 http://de.archive.ubuntu.com/ubuntu xenial-updates InRelease            Hit:4 http://de.archive.ubuntu.com/ubuntu xenial-backports InRelease Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [94,5 kB] Hit:6 http://dl.google.com/linux/chrome/deb stable Release          Ign:7 http://ppa.launchpad.net/kilian/f.lux/ubuntu xenial InRelease Ign:8 http://ppa.launchpad.net/kilian/f.lux/ubuntu xenial Release  Ign:9 http://ppa.launchpad.net/kili

  • Issue#1057807: Ubuntu - [SOLVED] Is it possible to combine multiple command-not-found handlers?

    Usually there is a default command_not_found_handle function defined in .bashrc file that suggests to install packages when command is not found. I want to define my own handler but still retain default behavior when my handler didn't handle a command. Is it possible? Maybe somehow give an old function a new name and then define a new command_not_found_handle()?

  • Issue#1082081: Autodesk - revit printing issue ( solved) due to windows update

    Uninstall (Windows 7) KB 3177725 and (Windows 10) KB 3176493 can solve printing issue: Revit could not start the print job because it was unable to connect to the specified printer. Check your printer connectivity and try again.  

  • Issue#1142067: Ubuntu - Issue with apt-get update on 10.04.4 LTS

    So trying to upgrade 10.04.4 LTS to a more recent version with no success. I have updated my sources to the old-releases as per the info on the ubuntu site, but still not getting anywhere. Seems something is corrupted, but I don't know how to fix it (other than trying what is said on the console which didn't look like a good option to continue with). Any advice appreciated. Jay Code: [email protected]:~# cat /etc/apt/sources.listdeb http://old-releases.ubuntu.com/ubuntu lucid main deb http://old-releases.ubuntu.com/ubuntu lucid-updates main deb http://old-releases.ubuntu.com/ubuntu lucid-security main [email protected]:~# apt-get update Hit http://old-releases.ubuntu.com lucid Release.gpg Hit http://old-releases.ubuntu.com/ubuntu/ lucid/main Translation-en_GB Hit http://old-releases.ubuntu.com lucid-updates Release.gpg Hit http://old-releases.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_GB Hit http://old-releases.ubuntu.com lucid-security Release.gpg Ign http://old-releases.ubunt

  • Issue#1145188: Ubuntu - [SOLVED] Upgrade from 14.04 to 16.04. Error found when loading /home/user/.profile

    Upgraded from 14.04 to 16.04 and receive the following error: Code: Error found when loading /home/username/.profile: /home/username/.profile: line 24 /opt/qt55/bin/qt55-env.sh: No such file or directory. As a result the session will not be configured correctly. You should fix the problem as soon as feasible. My /home/username/.profile has: Code: # ~/.profile: executed by the command interpreter for login shells. # This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login # exists. # see /usr/share/doc/bash/examples/startup-files for examples. # the files are located in the bash-doc package. # the default umask is set in /etc/profile; for setting the umask # for ssh logins, install and configure the libpam-umask package. #umask 022 # if running bash if [ -n "$BASH_VERSION" ]; then     # include .bashrc if it exists     if [ -f "$HOME/.bashrc" ]; then     . "$HOME/.bashrc"     fi fi # set P

  • Issue#1192331: Ubuntu - Can't update + home folder issue + can't get Xampp working

    Hi all lovely folks Intially, I was unable to get Xampp going. Here is the log http://pastebin.com/JwSnv9Z3 A lovely guy over at Apache friends suggested that it may be a disk error. I then recalled that I have had issues updating recently. More specially, I would get: So I cleared a lot of space. I followed some guides (updated where I collect the info from, removed som huge files (a game) Now when I ty update I get this I installed Bleepps to help clean. I noticed that even tho I ran as root, I got this error (But why deny me, I am root) I still clear some more space. I ralise that my home folder may not be big enough (Could be the issue, not sure). Q How do I know is Xampp is installed in home? Will it be installed by default? Note trying upgrade will post update

  • Issue#1193875: Ubuntu - [SOLVED] Dovecot doveadm scripting issue

    Have used script below with Dovecot forever to purge emails. #!/bin/bash # DOVEADM="/usr/bin/doveadm"; $DOVEADM expunge -A mailbox Drafts savedbefore 365d $DOVEADM expunge -A mailbox Sent savedbefore 365d $DOVEADM expunge -A mailbox Junk savedbefore 30d $DOVEADM expunge -A mailbox Trash savedbefore 30d On a new server, get: sudo: /script-name.sh: command not found yet using sudo doveadm expunge -A mailbox Drafts savedbefore 365d sudo doveadm expunge -A mailbox Sent savedbefore 365d sudo doveadm expunge -A mailbox Junk savedbefore 30d sudo doveadm expunge -A mailbox Trash savedbefore 30d As individual command works. Is there something wrong with original script?

  • Issue#250: Android - [Support] issue with upper left hand corner after verizon update on Samsung S5

    Very new to the forums and first time poster here. Be gentle my Android friends! [emoji6] Just updated my s5 to the most recent software pushed by Verizon and now I am having an issue I've never had before. The upper left hand corner, where most, if not all, apps use as their three bar "menu" button is no longer responsive. Using Reddit Is Fun as an example, and I can't access my subreddit menu. Anyone else having this issue or have any thoughts? I saw online someone stated that their... [Support] issue with upper left hand corner after verizon update on Samsung S5

  • Issue#2210: Ubuntu - Ubuntu 15.10 - Boot Issue

    Today I have installed ubuntu 15.10 on my Vaio laptop, then i installed nvidia proprietary driver from "Additional Drivers" and now when i boot (screen after grub menu) it gives me following error Code: --------- [8.764321] intel ips 0000:00:1f.6: thermal reporting for required devices not...

  • Issue#2164: Ubuntu - VPN issue (Astrill)

    So weird issue here... Trying out Kubuntu for the first time (15.04) and as I live in China I need a VPN to access, well, anything useful. Astrill works fine at first, went to their site, downloaded the deb and installed it and it works fine except for one thing: It only works with the account I was using when I installed it. I installed it using my Admin account, and then switched to a regular user account, no luck. If I launch it, the icon bounces like it's launching and then nothing. I tried launching it with a second admin account..same thing. If I reinstall it in the second account, it launches but then the original account cannot use it. So basically, any time I wish to switch accounts I need to reinstall the package? That's weird. Anyone heard of anything like this before? FWIW, I have had similar issues with various codecs. Video plays fine, but only for the account that I used to install the media player with. (mainly for SMplayer) Help?

  • Issue#2271: Linux - [SOLVED] Bash script : event not found when I echo my password into ssh

    Hi all I am automating some ssh connections on my laptop. I use this bash script: echo my!pass | ssh hostname I get this: -bash: !pass: event not found Well, my password contains ! and I really don't like to change it. What does this mean and how can I fix it? Please note: I can't use expect Error seen on SunOS and MAC El Capitan Thanks!

  • Issue#2727: Linux - [SOLVED] bash: ping: command not found

    Hello. why "ping" command not exist on Debian Jessie x64 by default? $ /bin/p pidof ps pwd $ /usr/sbin/p pam-auth-update pppdump pwck pam_getenv pppoe-discovery pwconv pam_timestamp_check pppstats pwunconv paperconfig psad pppd psadwatchd I installed "inetutils-tools" and "inetutils-ping" for solve this problem.